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1. Introduction

Group Policy is a collection of settings used to add additional controls to the working environment of both 

user and computer accounts. Group Policy helps enforce password policies, deploy patches, disable USB 

drives, disable PST file creation, and more. Group Policy helps strengthen your organizations' IT security 

posture by closely regulating critical policies such as password change, account lockout, and more.

1.1 Overview

2. Supported systems

3. Configuring domain controllers

1.2 Benefits of auditing Group Policy Objects using ADAudit Plus

2.1 Supported Windows Server versions

3.1 Automatic process

Audit, alert, and report on Group Policy Object (GPO) creation, deletion, modification,

history, and more.

Monitor who made what setting changes to your GPOs and from where in real time.

Generate granular reports on the new and old values of all GPO setting changes.

Keep a close eye on critical policy changes like changes to account lockout policy and password

change policy to detect and respond to malicious activities instantly.

And much more.

1.  Log in to any computer with Active Directory Users and Computers.

2.  Go to Start > Windows Administrative Tools > Active Directory Users and Computers.

3.  Right-click on the domain and select Operations Masters.

4.  In the operations master window that opens, click the PDC tab at the top.

Windows Server 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2, 2016, 2016 R2, 2019, 2022, and 2025.

Check whether the configured domain controller is a primary domain controller (PDC)

using the following steps.
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5.  Under Operations master is the name of the server configured as the PDC.

6.  Click Close.

7.  Open ADAudit Plus.

8.  Click Domain Settings in the top right corner.

9.  Under Available Domain Controllers, ensure that the PDC has been configured.

10.  If not, Select +Add Domain Controllers, and choose one.

       Note: If ADAudit Plus is unable to discover your domain controller, you can manually type it in. 

11.  Click Save.

Notes:

To perform GPO setting change auditing, you only need to configure the PDC.

GPO management auditing, on the other hand, requires configuring all the domain controllers

that have been licensed.
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4. Configuring the audit policies

4.1 Automatic process

4.2 Manual process

1.  Open ADAudit Plus.

2.  Go to Admin > Domain Settings. Click Audit Policy: Configure in the top-right corner.

1.  Using domain admin credentials, log in to any computer that has the Group Policy Management

     Console (GPMC) on it.

     Note: The GPMC will not be installed in workstations and/or enabled in member servers by default.

     Hence, we recommend configuring audit policies in Windows domain controllers.

2.  Go to Start > Windows Administrative Tools > Group Policy Management.

3.  In the GPMC, select Domains and choose the domain you want to configure Group Policy for.

     Select Domain Controller, right-click the Default Domain Controllers Policy, and select Edit.

Configure the audit policies automatically using the steps below:

Configure the audit policies manually using the steps below:

Note: ADAudit Plus can automatically configure the required audit policies for GPO auditing. After clicking

Audit Policy: Configure in the above step, you can either choose Yes to let ADAudit Plus automatically

configure the required audit policies, or choose No to manually configure them.
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4.  In the Group Policy Management Editor, follow the steps below:

5.  Choose Computer configuration > Policies > Windows Settings > Security settings >

     Advanced Audit Policy Configuration > Audit Policies.

6.  Click, enable, and save the audit policies as shown below:

Note: Advanced audit policy configuration will only be available in Windows Server 2008 or later.

If you have an older version of Windows, configure legacy audit policies.

Advanced audit policies

Advanced audit policy

Category Subcategory

DS Access Audit Directory Service Access

Audit Directory Service Changes

Success

Success

Audit events

4

https://www.manageengine.com/products/active-directory-audit/?source=gpoauditguide


7.  Choose Computer configuration > Policies > Windows Settings > Security Settings >

     Local Policies > Audit Policies.

8.  Click, enable, and save the audit policies as shown below:

Local audit policies

Local audit policy

Category

Audit directory service access Success

Audit events

5. Configuring object-level auditing

5.1 Automatic process

1.  Open ADAudit Plus.

2.  Go to Reports > GPO Management > GPO History > Object-level auditing needs to be

     configured for getting proper reports: Configure.

Automatic configuration of object-level auditing requires the user's consent.

To configure object-level auditing automatically:
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5.2 Manual process

1.  Using domain admin credentials, log in to any computer that has Active Directory Users

     and Computers on it.

2.  Go to Start > Windows Administrative Tools > Active Directory Users and Computers.

3.  Click View > Advanced features.

4.  Right-click on the domain, and go to Properties > Security > Advanced > Auditing > Add.

Configure object-level auditing manually using the steps below:

5.  In the Auditing Entry window, click Select a principal. Under Enter the object name to select,

     type in Everyone, and click OK.

6. Select Type: Success. Select the appropriate permissions as directed below.

Note: Use Clear all to remove all permissions and properties before selecting the appropriate

permissions.
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6. Configuring the security log size and the retention settings

6.1 Configuring the security log size

1. Go to Start > Windows Administrative Tools > Group Policy Management.

2. In the GPMC, right-click the GPO "domain name"_ADAudit Plus Audit policy, and select Edit.

3. In the Group Policy Management Editor, choose Computer configuration > Policies >

     Windows settings > Security settings > Event Log > Retention Method for Security Log.

Configure the security log size for Group Policy audit data using the steps below:

Auditing
entry number

Auditing
entry for Access Apply to Windows

Server 2003

Apply to Windows
Server 2008/Windows
Server 2012

3 and 4 GPO Create groupPolicy
Container objects

Delete groupPolicy
Container objects

This object and all
child objects

This object and all
descendant objects

Write all properties

Delete

Modify permissions

groupPolicyContainer
objects 

Descendant groupPolicy
Container objects
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6.2 Configuring the retention settings

1. Open ADAudit Plus.

2. Go to Admin > Configuration > Archive Events.

3. Click Archive Folder on the right and specify the location where you wish to store the archive files.

4. Scroll down to GPO Management, then click the Enable icon and the gear icon under the Actions

    column to open the Archive Settings pop-up.

5. Under Live Tier, specify the Hot Data Retention Time in days, months, or years.

6. Under Archive Tier, check the Retain data indefinitely box if you want to retain archive data forever.

    Alternatively, uncheck it and specify the Frozen Data Retention Time in days, months, or years.

7. Click Save.

4.  Check Define these policy settings, and select Overwrite events as needed.

5.  Click OK.

Configure the retention settings for Group Policy audit data using the steps below:

Note: Learn more about archive tiers and the various states of data on the Archive Events page. 
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7. Installing the Group Policy Management Console (GPMC)

8. Configuring auditing for GPO settings changes

For Windows Server 2012 and above

1. Go to Start > Control Panel, and select Turn Windows features on and off under Programs.

2. In the Add Roles and Feature Wizard window that opens, select Features.  

3. Check Group Policy Management, and click Next.

4. Click Install.

For Windows Server 2008 and 2008 R2

1. Go to Start > Control Panel, and Select Turn Windows features on and off under Programs.

2. In the Server manager window select Features > Add features.  

3. Check Group Policy Management, and click Next.

4. Click Install.

Follow the steps below to enable and configure GPO settings change auditing:

1. Open ADAudit Plus.

2. Go to Admin > Configuration > GPO settings changes.

3. Select the Domain from the drop-down.

4. Enable GPO settings changes. The Primary Domain Controller Name will be automatically selected.

     If it is not selected, you can click the Discover PDC button.

5. Choose whether you want to audit with or without an agent.

6. Click Save.

The GPMC must be installed on the machine used to run ADAudit Plus. Install GPMC in the machine

running ADAudit Plus using the steps below:

Note: Once the GPMC is installed, open ADAudit Plus console > Reports > GPO Settings Changes > Group 

Policy Settings Changes. An error message will be displayed on top that says "Please install GPMC in the 

computer where ADAudit Plus is installed. After you install GPMC please Click here." Go ahead and click 

the Click here hyperlink to begin advanced GPO report generation in ADAudit Plus.

Enable audits for GPO settings changes to monitor critical GPO settings changes, such as computer and 

user configuration changes, password policy changes, permission changes, and administrative template 

changes, in real time. You can find the relevant reports under Active Directory > GPO Setting Changes.

Note: Ensure that the share path \\"machine_name"\sysvol is accessible from the machine that has

ADAudit Plus installed on it. 
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9. Troubleshooting

Troubleshooting

1. Ping the PDC by its flat name and fully qualified domain name (FQDN) from the ADAudit Plus server.

a. Open File Explorer on the ADAudit Plus server and access the SYSVOL folder using your PDC's flat

name and FQDN (\\PDC Name\sysvol).

b. If you are not able to access it, append the DNS suffix on the ADAudit Plus server either by adding

an entry in the Advanced TCP/IP Settings or by adding a host record on the DNS server and mapping

this name to the server's IP address.

2. Ensure that the RPC ports (static port 135 and dynamic ports 49152–65535) are open. Follow this

port guide to open the required RPC ports.

3. Enable the agent-based GPO watcher to avoid all network errors:

a. Open ADAudit Plus.

b. Go to Admin > Configuration > GPO settings changes.

c. Enable the Watch via agent option.

d. Click Save.

Network path not found: Error code 35/53

Cause

This error occurs when the PDC's SYSVOL share is not accessible from the ADAudit Plus server.
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Troubleshooting

1. Enable hardened UNC paths:

a. Confirm that the user configured in the ADAudit Plus console has read permissions over
    the following share: 
    \\<PDC Name>\SysVol\<Domain Name>\Policies\

b. If they have read permissions, open the Local Group Policy Editor on the ADAudit Plus server
    (gpedit.msc). 

c. Go to Computer Configuration > Administrative Templates > Network > Network Provider.

d. Double-click Hardened UNC Paths and click Enabled.

e. In the Options section, scroll down and click Show.

f. Add the following entry:

i. Under the Value name column, type the following:
\\*\SYSVOL

ii. Under the Value column, type the following: RequireMutualAuthentication=0,RequireIntegrity=
0,RequirePrivacy=0 

g. Click OK.

2. Enable the agent-based GPO watcher to avoid all network errors:

a. Open ADAudit Plus.

b. Go to Admin > Configuration > GPO settings changes.

c. Enable the Watch via agent option.

d. Click Save.

Network access denied: Error code 65/41

Cause

This error occurs when the configured user does not have read access to the SYSVOL folder.

Troubleshooting

1. Follow this port guide to open the RPC ports required for the ADAudit Plus server to access the

    target machine.

2. Enable the agent-based GPO watcher to avoid all network errors:

a. Open ADAudit Plus.

b. Go to Admin > Configuration > GPO settings changes.

c. Enable the Watch via agent option.

d. Click Save.

The RPC server is unavailable: Error code 6ba

Cause

This error occurs when the RPC ports (static port 135 and dynamic ports 49152–65535) are not
opened in the firewall.
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Our Products

AD360   |   Log360   |   ADManager Plus   |   ADSelfService Plus

DataSecurity Plus   |   M365 Manager Plus

Get Quote Download

ADAudit Plus is a unified auditing solution that provides full visibility into activities across 
Active Directory (AD), Entra ID, file servers (Windows, NetApp, EMC and more), Windows 
servers and workstations—all in just a few clicks. ADAudit Plus helps organizations 
streamline auditing, demonstrate compliance and enhance their identity threat detection 
and response with capabilities like real-time change auditing, user logon tracking, account 
lockout analysis, privileged user monitoring, file auditing, compliance reporting, attack 
surface analysis (for AD, Azure, AWS, and GCP), UBA, response automation and AD backup 
and recovery.

For more information about ADAudit Plus, visit 
www.manageengine.com/products/active-directory-audit/.

About ADAudit Plus
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